librelist archives

« back to archive

[PROGRESS] Angular app can show messages and users, and send messages (sort of)

[PROGRESS] Angular app can show messages and users, and send messages (sort of)

From:
Josh Adams
Date:
2013-09-21 @ 01:40
So the unit tests and general in-browser testing for the local pubsub bits
in the angular app for all the important bits (except room changing) is
complete, but it's not yet hooked into the erlang chatserver backend.  This
is primarily because my environment seems borked somehow (not really sure).
 The chromechat tests were failing for me, but work on travis-ci - entirely
possible something silly's going on.

Nathan, did you have any luck running them on your machine?

-- 
*Josh Adams*
CTO | isotope|eleven <http://www.isotope11.com>
[cell] (205) 215-3957
[work] (877) 476-8671 x201

Re: [PROGRESS] Angular app can show messages and users, and send messages (sort of)

From:
Josh Adams
Date:
2013-09-21 @ 01:46
So I checked out the repo into another directory, and the tests weren't
failing.  Strange.  Anyway, that wasted a good twenty minutes of me and
nathan's hacking today... :(


On Fri, Sep 20, 2013 at 8:40 PM, Josh Adams <josh@isotope11.com> wrote:

> So the unit tests and general in-browser testing for the local pubsub bits
> in the angular app for all the important bits (except room changing) is
> complete, but it's not yet hooked into the erlang chatserver backend.  This
> is primarily because my environment seems borked somehow (not really sure).
>  The chromechat tests were failing for me, but work on travis-ci - entirely
> possible something silly's going on.
>
> Nathan, did you have any luck running them on your machine?
>
> --
> *Josh Adams*
> CTO | isotope|eleven <http://www.isotope11.com>
> [cell] (205) 215-3957
> [work] (877) 476-8671 x201
>



-- 
*Josh Adams*
CTO | isotope|eleven <http://www.isotope11.com>
[cell] (205) 215-3957
[work] (877) 476-8671 x201

Re: [chromechat] Re: [PROGRESS] Angular app can show messages and users, and send messages (sort of)

From:
Nathan Stott
Date:
2013-09-21 @ 15:28
Yeh, they worked for me too. Wonder what was going on? Strange that it
worked after you checked it out to another directory.


On Fri, Sep 20, 2013 at 8:46 PM, Josh Adams <josh@isotope11.com> wrote:

> So I checked out the repo into another directory, and the tests weren't
> failing.  Strange.  Anyway, that wasted a good twenty minutes of me and
> nathan's hacking today... :(
>
>
> On Fri, Sep 20, 2013 at 8:40 PM, Josh Adams <josh@isotope11.com> wrote:
>
>> So the unit tests and general in-browser testing for the local pubsub
>> bits in the angular app for all the important bits (except room changing)
>> is complete, but it's not yet hooked into the erlang chatserver backend.
>>  This is primarily because my environment seems borked somehow (not really
>> sure).  The chromechat tests were failing for me, but work on travis-ci -
>> entirely possible something silly's going on.
>>
>> Nathan, did you have any luck running them on your machine?
>>
>> --
>> *Josh Adams*
>> CTO | isotope|eleven <http://www.isotope11.com>
>> [cell] (205) 215-3957
>> [work] (877) 476-8671 x201
>>
>
>
>
> --
> *Josh Adams*
> CTO | isotope|eleven <http://www.isotope11.com>
> [cell] (205) 215-3957
> [work] (877) 476-8671 x201
>



-- 
Thanks,
Nathan Stott
Whiteboard-IT