librelist archives

« back to archive

Fixed issue with Mercurial 1.6

Fixed issue with Mercurial 1.6

From:
Jochen Breuer
Date:
2010-09-15 @ 06:55
hginitializer now works with Mercurial 1.6. Apparently Mercurial had
an API change in version 1.6.

The workaround is rather simple:

    # Mercurial <= 1.5
    repo.add(['.hgignore'])

    # Mercurial >= 1.6
    repo[None].add(['.hgignore'])

Can be found in changeset:
http://bitbucket.org/brejoc/hginitializer/changeset/71d244687099