librelist archives

« back to archive

Versions and compatibility

Versions and compatibility

From:
Thibaut Barrère
Date:
2010-08-09 @ 11:40
Hi,

I'm just wondering: is it possible for a 1.5.0 worker to consume messages
pushed by a more recent client ?

As well, does Resque work with Redis 1.2 these days, too ?

thanks!

-- Thibaut

Re: [resque] Versions and compatibility

From:
Chris Wanstrath
Date:
2010-08-09 @ 17:48
On Mon, Aug 9, 2010 at 4:40 AM, Thibaut Barrère
<thibaut.barrere@gmail.com> wrote:

> I'm just wondering: is it possible for a 1.5.0 worker to consume messages
> pushed by a more recent client ?

Yes. Resque takes backwards compatibility very seriously and follows
Semantic Versioning: http://semver.org/

> As well, does Resque work with Redis 1.2 these days, too ?

Yep!

Re: [resque] Versions and compatibility

From:
Thibaut Barrère
Date:
2010-08-09 @ 17:50
>
> Yes. Resque takes backwards compatibility very seriously and follows
> Semantic Versioning: http://semver.org/
>
> > As well, does Resque work with Redis 1.2 these days, too ?
>
> Yep!
>

Thanks! That's amazing :)

-- Thibaut