librelist archives

« back to archive

Fwd: Rails & Resque 2.0.0.pre.1

Fwd: Rails & Resque 2.0.0.pre.1

From:
Tim Hansen
Date:
2013-04-05 @ 14:00
I'm having trouble running the 2.0.0.pre.1 version of the gem. It has a
requirement of thor ~> 0.17, but a number of other gems require thor ~>
0.14 (including railties at 0.14.4). I'm running rails 3.0.19. What's the
minimum Rails version required to get the gem running?

Re: [resque] Fwd: Rails & Resque 2.0.0.pre.1

From:
Steve Klabnik
Date:
2013-04-05 @ 14:05
> I'm running rails 3.0.19

Please please please IMMEDIATELY upgrade to 3.0.20:

http://weblog.rubyonrails.org/2013/1/28/Rails-3-0-20-and-2-3-16-have-been-released/

Also, please upgrade off of 3.0.x, as it's no longer supported, and there's
already been one other major security release that affects it, but it's not
maintained any more:

http://weblog.rubyonrails.org/2013/3/18/SEC-ANN-Rails-3-2-13-3-1-12-and-2-3-18-have-been-released/


--------------------------------------------------------------------

Resque 2.0.0 is _not_ ready for any kind of production release yet, I'm not
even really sure that it's in beta shape yet.

We're not sure what versions of Rails Resque 2.0 will support yet. I'd like
to keep it as broad as possible, but we haven't made any commitments.

Re: [resque] Fwd: Rails & Resque 2.0.0.pre.1

From:
Tim Hansen
Date:
2013-04-05 @ 14:08
In that case, how hard would it be for me to implement the Resque.queued
method into the current stable release?


On Fri, Apr 5, 2013 at 10:05 AM, Steve Klabnik <steve@steveklabnik.com>wrote:

> > I'm running rails 3.0.19
>
> Please please please IMMEDIATELY upgrade to 3.0.20:
> 
http://weblog.rubyonrails.org/2013/1/28/Rails-3-0-20-and-2-3-16-have-been-released/
>
> Also, please upgrade off of 3.0.x, as it's no longer supported, and
> there's already been one other major security release that affects it, but
> it's not maintained any more:
> 
http://weblog.rubyonrails.org/2013/3/18/SEC-ANN-Rails-3-2-13-3-1-12-and-2-3-18-have-been-released/
>
>
> --------------------------------------------------------------------
>
> Resque 2.0.0 is _not_ ready for any kind of production release yet, I'm
> not even really sure that it's in beta shape yet.
>
> We're not sure what versions of Rails Resque 2.0 will support yet. I'd
> like to keep it as broad as possible, but we haven't made any commitments.
>

Re: [resque] Fwd: Rails & Resque 2.0.0.pre.1

From:
Steve Klabnik
Date:
2013-04-05 @ 14:09
Unsure.