librelist archives

« back to archive

Which rubies should Resque support?

Which rubies should Resque support?

From:
Steve Klabnik
Date:
2013-06-27 @ 07:05
https://github.com/resque/resque/pull/1060

Thoughts?

1.8.7 is still used by some people, even though it's dying in days. I
think dropping < 1.9.3 would be fine for 2.0, but I want to hear what
you all think.

Re: [resque] Which rubies should Resque support?

From:
Piotr Szotkowski
Date:
2013-06-27 @ 08:35
Steve Klabnik:

> https://github.com/resque/resque/pull/1060

> Thoughts?

+1 on dropping Ruby 1.8 support.

> I think dropping < 1.9.3 would be fine for
> 2.0, but I want to hear what you all think.

I’d go as far as officially support only Ruby 2 and just make
sure Resque 2 is green on 1.9.3 while Ruby 1.9 is popular.

Ruby 1.9 → 2.0 upgrade is usually not painful and should
be encouraged; dropping actual Ruby 1.9 support sometime
in Resque 2.x might be a desirable option to have.

— Piotr ‘keyword arguments FTW’ Szotkowski
-- 
You are trapped in a maze of screens and ssh sessions all alike.
It is dark, and you are likely to log off the wrong account.
                                                     [Nep., asr]


Re: [resque] Which rubies should Resque support?

From:
Einar Jónsson
Date:
2013-06-27 @ 09:30
Ruby 1.8.7 end-of-life is this month, meaning that it won't even be 
getting security patches. (See 
http://www.ruby-lang.org/en/news/2011/10/06/plans-for-1-8-7/).

So, +1 on dropping Ruby 1.8.7 support.

Also, +1 on only supporting Ruby 2 officially while keeping the 1.9.3 
tests green for a while.

# Einar


On Jun 27, 2013, at 8:35 AM, Piotr Szotkowski <chastell@chastell.net> wrote:

> Steve Klabnik:
> 
>> https://github.com/resque/resque/pull/1060
> 
>> Thoughts?
> 
> +1 on dropping Ruby 1.8 support.
> 
>> I think dropping < 1.9.3 would be fine for
>> 2.0, but I want to hear what you all think.
> 
> I’d go as far as officially support only Ruby 2 and just make
> sure Resque 2 is green on 1.9.3 while Ruby 1.9 is popular.
> 
> Ruby 1.9 → 2.0 upgrade is usually not painful and should
> be encouraged; dropping actual Ruby 1.9 support sometime
> in Resque 2.x might be a desirable option to have.
> 
> — Piotr ‘keyword arguments FTW’ Szotkowski
> -- 
> You are trapped in a maze of screens and ssh sessions all alike.
> It is dark, and you are likely to log off the wrong account.
>                                                     [Nep., asr]
> 
> 
> 

Re: [resque] Which rubies should Resque support?

From:
Steve Klabnik
Date:
2013-06-28 @ 09:20
I have merged this pull request, but as I mention in the ticket, if
anyone wants to make a case for 1.8.7, I will gladly hear it.

Thank you all for the feedback.