librelist archives

« back to archive

Website updated to Express

Website updated to Express

From:
Gilmore Davidson
Date:
2012-11-24 @ 11:31
Hi all,

As Sharkie briefly mentioned at the last SydJS, I've upgraded sydjs.com to
use Express 3.0 (instead of the old hand-rolled solution that Heroku forced
upon us to begin with).

I pretty much just directly ported what we had over to Express, so there's
definitely room for improvement. I also updated the readme to be a bit more
useful for anyone who wants to work on the site.

Speaking of helping... we've still got the features wishlist available in
the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist
*hint hint*

Cheers,
Gil

Re: [sydjs] Website updated to Express

From:
Lachlan Hardy
Date:
2012-11-25 @ 00:10
Awesome work, Gil!


On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson
<gilmoreorless@gmail.com>wrote:

> Hi all,
>
> As Sharkie briefly mentioned at the last SydJS, I've upgraded 
sydjs.comto use Express 3.0 (instead of the old hand-rolled solution that 
Heroku
> forced upon us to begin with).
>
> I pretty much just directly ported what we had over to Express, so there's
> definitely room for improvement. I also updated the readme to be a bit more
> useful for anyone who wants to work on the site.
>
> Speaking of helping... we've still got the features wishlist available in
> the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist
> *hint hint*
>
> Cheers,
> Gil
>

Re: [sydjs] Website updated to Express

From:
Ben Taylor
Date:
2012-11-25 @ 05:42
Hey there, 

I'm trying to get this running (thought I might poke around a node app, 
never have before).

I have node 0.8.14, npm 1.1.0 and successfully installed the packages. 
When I run foreman start it sits there and nothing happens. Doesn't seem 
to be accepting connections on 8001 either.

Any ideas?

 - Ben


On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:

> Awesome work, Gil!
> 
> 
> On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson 
<gilmoreorless@gmail.com (mailto:gilmoreorless@gmail.com)> wrote:
> > Hi all,
> > 
> > As Sharkie briefly mentioned at the last SydJS, I've upgraded 
sydjs.com (http://sydjs.com) to use Express 3.0 (instead of the old 
hand-rolled solution that Heroku forced upon us to begin with). 
> > 
> > I pretty much just directly ported what we had over to Express, so 
there's definitely room for improvement. I also updated the readme to be a
bit more useful for anyone who wants to work on the site. 
> > 
> > Speaking of helping... we've still got the features wishlist available
in the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist 
> > *hint hint*
> > 
> > Cheers,
> > Gil
> > 
> 
> 
> 

Re: [sydjs] Website updated to Express

From:
David Hong
Date:
2012-11-25 @ 06:11
Foreman defaults to port 5000 I think. Did you try port 5000?

Sent from my iPhone

On 25/11/2012, at 4:42 PM, Ben Taylor <me@taybenlor.com> wrote:

> Hey there, 
> 
> I'm trying to get this running (thought I might poke around a node app, 
never have before).
> 
> I have node 0.8.14, npm 1.1.0 and successfully installed the packages. 
When I run foreman start it sits there and nothing happens. Doesn't seem 
to be accepting connections on 8001 either.
> 
> Any ideas?
> 
>  - Ben
> 
> On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:
> 
>> Awesome work, Gil!
>> 
>> 
>> On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson 
<gilmoreorless@gmail.com> wrote:
>>> Hi all,
>>> 
>>> As Sharkie briefly mentioned at the last SydJS, I've upgraded 
sydjs.com to use Express 3.0 (instead of the old hand-rolled solution that
Heroku forced upon us to begin with).
>>> 
>>> I pretty much just directly ported what we had over to Express, so 
there's definitely room for improvement. I also updated the readme to be a
bit more useful for anyone who wants to work on the site.
>>> 
>>> Speaking of helping... we've still got the features wishlist available
in the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist
>>> *hint hint*
>>> 
>>> Cheers,
>>> Gil
> 

Re: [sydjs] Website updated to Express

From:
Ben Taylor
Date:
2012-11-25 @ 06:18
Aha! That worked. I'd poked through the app code and it had a default of 
8001 specified. 

Thanks! 

 - Ben


On Sunday, 25 November 2012 at 5:11 PM, David Hong wrote:

> Foreman defaults to port 5000 I think. Did you try port 5000?
> 
> Sent from my iPhone
> 
> On 25/11/2012, at 4:42 PM, Ben Taylor <me@taybenlor.com 
(mailto:me@taybenlor.com)> wrote:
> 
> > Hey there, 
> > 
> > I'm trying to get this running (thought I might poke around a node 
app, never have before).
> > 
> > I have node 0.8.14, npm 1.1.0 and successfully installed the packages.
When I run foreman start it sits there and nothing happens. Doesn't seem 
to be accepting connections on 8001 either.
> > 
> > Any ideas?
> > 
> >  - Ben
> > 
> > 
> > On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:
> > 
> > > Awesome work, Gil!
> > > 
> > > 
> > > On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson 
<gilmoreorless@gmail.com (mailto:gilmoreorless@gmail.com)> wrote:
> > > > Hi all,
> > > > 
> > > > As Sharkie briefly mentioned at the last SydJS, I've upgraded 
sydjs.com (http://sydjs.com) to use Express 3.0 (instead of the old 
hand-rolled solution that Heroku forced upon us to begin with). 
> > > > 
> > > > I pretty much just directly ported what we had over to Express, so
there's definitely room for improvement. I also updated the readme to be a
bit more useful for anyone who wants to work on the site. 
> > > > 
> > > > Speaking of helping... we've still got the features wishlist 
available in the wiki: 
https://github.com/sydjs/sydjs/wiki/Website-wishlist 
> > > > *hint hint*
> > > > 
> > > > Cheers,
> > > > Gil
> > > > 
> > > 
> > > 
> > > 
> > 

Re: [sydjs] Website updated to Express

From:
Ben Taylor
Date:
2012-11-25 @ 06:29
Woah. The whole site is one big SVG? That's different. 

 - Ben


On Sunday, 25 November 2012 at 5:18 PM, Ben Taylor wrote:

> Aha! That worked. I'd poked through the app code and it had a default of
8001 specified. 
> 
> Thanks! 
> 
>  - Ben
> 
> 
> On Sunday, 25 November 2012 at 5:11 PM, David Hong wrote:
> 
> > Foreman defaults to port 5000 I think. Did you try port 5000?
> > 
> > Sent from my iPhone
> > 
> > On 25/11/2012, at 4:42 PM, Ben Taylor <me@taybenlor.com 
(mailto:me@taybenlor.com)> wrote:
> > 
> > > Hey there, 
> > > 
> > > I'm trying to get this running (thought I might poke around a node 
app, never have before).
> > > 
> > > I have node 0.8.14, npm 1.1.0 and successfully installed the 
packages. When I run foreman start it sits there and nothing happens. 
Doesn't seem to be accepting connections on 8001 either.
> > > 
> > > Any ideas?
> > > 
> > >  - Ben
> > > 
> > > 
> > > On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:
> > > 
> > > > Awesome work, Gil!
> > > > 
> > > > 
> > > > On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson 
<gilmoreorless@gmail.com (mailto:gilmoreorless@gmail.com)> wrote:
> > > > > Hi all,
> > > > > 
> > > > > As Sharkie briefly mentioned at the last SydJS, I've upgraded 
sydjs.com (http://sydjs.com) to use Express 3.0 (instead of the old 
hand-rolled solution that Heroku forced upon us to begin with). 
> > > > > 
> > > > > I pretty much just directly ported what we had over to Express, 
so there's definitely room for improvement. I also updated the readme to 
be a bit more useful for anyone who wants to work on the site. 
> > > > > 
> > > > > Speaking of helping... we've still got the features wishlist 
available in the wiki: 
https://github.com/sydjs/sydjs/wiki/Website-wishlist 
> > > > > *hint hint*
> > > > > 
> > > > > Cheers,
> > > > > Gil
> > > > > 
> > > > 
> > > > 
> > > > 
> > > 
> 

Re: [sydjs] Website updated to Express

From:
Lachlan Hardy
Date:
2012-11-26 @ 01:13
It was a quick hack put together in an hour or so nearly two years ago.

One of the main reasons we keep saying it'd be nice if someone found the
time to redesign it. :)


On Sun, Nov 25, 2012 at 5:29 PM, Ben Taylor <me@taybenlor.com> wrote:

>  Woah. The whole site is one big SVG? That's different.
>
>  - Ben
>
> On Sunday, 25 November 2012 at 5:18 PM, Ben Taylor wrote:
>
>  Aha! That worked. I'd poked through the app code and it had a default of
> 8001 specified.
>
> Thanks!
>
>  - Ben
>
> On Sunday, 25 November 2012 at 5:11 PM, David Hong wrote:
>
> Foreman defaults to port 5000 I think. Did you try port 5000?
>
> Sent from my iPhone
>
> On 25/11/2012, at 4:42 PM, Ben Taylor <me@taybenlor.com> wrote:
>
>  Hey there,
>
> I'm trying to get this running (thought I might poke around a node app,
> never have before).
>
> I have node 0.8.14, npm 1.1.0 and successfully installed the packages.
> When I run foreman start it sits there and nothing happens. Doesn't seem to
> be accepting connections on 8001 either.
>
> Any ideas?
>
>  - Ben
>
> On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:
>
> Awesome work, Gil!
>
>
> On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson <
> gilmoreorless@gmail.com> wrote:
>
> Hi all,
>
> As Sharkie briefly mentioned at the last SydJS, I've upgraded 
sydjs.comto use Express 3.0 (instead of the old hand-rolled solution that 
Heroku
> forced upon us to begin with).
>
> I pretty much just directly ported what we had over to Express, so there's
> definitely room for improvement. I also updated the readme to be a bit more
> useful for anyone who wants to work on the site.
>
> Speaking of helping... we've still got the features wishlist available in
> the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist
> *hint hint*
>
> Cheers,
> Gil
>
>
>
>
>
>

Re: [sydjs] Website updated to Express

From:
Jason Berry
Date:
2012-11-26 @ 23:35
I've added some logging when the server starts to print the port the server
is running on, which should help clear this up.


On 25 November 2012 17:18, Ben Taylor <me@taybenlor.com> wrote:

>  Aha! That worked. I'd poked through the app code and it had a default of
> 8001 specified.
>
> Thanks!
>
>  - Ben
>
> On Sunday, 25 November 2012 at 5:11 PM, David Hong wrote:
>
> Foreman defaults to port 5000 I think. Did you try port 5000?
>
> Sent from my iPhone
>
> On 25/11/2012, at 4:42 PM, Ben Taylor <me@taybenlor.com> wrote:
>
>  Hey there,
>
> I'm trying to get this running (thought I might poke around a node app,
> never have before).
>
> I have node 0.8.14, npm 1.1.0 and successfully installed the packages.
> When I run foreman start it sits there and nothing happens. Doesn't seem to
> be accepting connections on 8001 either.
>
> Any ideas?
>
>  - Ben
>
> On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:
>
> Awesome work, Gil!
>
>
> On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson <
> gilmoreorless@gmail.com> wrote:
>
> Hi all,
>
> As Sharkie briefly mentioned at the last SydJS, I've upgraded 
sydjs.comto use Express 3.0 (instead of the old hand-rolled solution that 
Heroku
> forced upon us to begin with).
>
> I pretty much just directly ported what we had over to Express, so there's
> definitely room for improvement. I also updated the readme to be a bit more
> useful for anyone who wants to work on the site.
>
> Speaking of helping... we've still got the features wishlist available in
> the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist
> *hint hint*
>
> Cheers,
> Gil
>
>
>
>
>

Re: [sydjs] Website updated to Express

From:
Sugendran Ganess
Date:
2012-11-26 @ 23:54
Is there a list/google group where we can discuss options for the
website? I've been writing nodejs fulltime for the last year and have
a few ideas on things we can do. I figure spamming everyone with that
conversation is probably a bad thing.

On 27 November 2012 10:35, Jason Berry <jason@thevagabond.net> wrote:
> I've added some logging when the server starts to print the port the server
> is running on, which should help clear this up.
>
>
> On 25 November 2012 17:18, Ben Taylor <me@taybenlor.com> wrote:
>>
>> Aha! That worked. I'd poked through the app code and it had a default of
>> 8001 specified.
>>
>> Thanks!
>>
>>  - Ben
>>
>> On Sunday, 25 November 2012 at 5:11 PM, David Hong wrote:
>>
>> Foreman defaults to port 5000 I think. Did you try port 5000?
>>
>> Sent from my iPhone
>>
>> On 25/11/2012, at 4:42 PM, Ben Taylor <me@taybenlor.com> wrote:
>>
>> Hey there,
>>
>> I'm trying to get this running (thought I might poke around a node app,
>> never have before).
>>
>> I have node 0.8.14, npm 1.1.0 and successfully installed the packages.
>> When I run foreman start it sits there and nothing happens. Doesn't seem to
>> be accepting connections on 8001 either.
>>
>> Any ideas?
>>
>>  - Ben
>>
>> On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:
>>
>> Awesome work, Gil!
>>
>>
>> On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson
>> <gilmoreorless@gmail.com> wrote:
>>
>> Hi all,
>>
>> As Sharkie briefly mentioned at the last SydJS, I've upgraded sydjs.com to
>> use Express 3.0 (instead of the old hand-rolled solution that Heroku forced
>> upon us to begin with).
>>
>> I pretty much just directly ported what we had over to Express, so there's
>> definitely room for improvement. I also updated the readme to be a bit more
>> useful for anyone who wants to work on the site.
>>
>> Speaking of helping... we've still got the features wishlist available in
>> the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist
>> *hint hint*
>>
>> Cheers,
>> Gil
>>
>>
>>
>>
>

Re: [sydjs] Website updated to Express

From:
Ben Taylor
Date:
2012-11-26 @ 23:58
That'd be cool. 

I sketched out a new design last night and have some ideas.

Perhaps we should use GitHub issues? 

 - Ben


On Tuesday, 27 November 2012 at 10:54 AM, Sugendran Ganess wrote:

> Is there a list/google group where we can discuss options for the
> website? I've been writing nodejs fulltime for the last year and have
> a few ideas on things we can do. I figure spamming everyone with that
> conversation is probably a bad thing.
> 
> On 27 November 2012 10:35, Jason Berry <jason@thevagabond.net 
(mailto:jason@thevagabond.net)> wrote:
> > I've added some logging when the server starts to print the port the server
> > is running on, which should help clear this up.
> > 
> > 
> > On 25 November 2012 17:18, Ben Taylor <me@taybenlor.com 
(mailto:me@taybenlor.com)> wrote:
> > > 
> > > Aha! That worked. I'd poked through the app code and it had a default of
> > > 8001 specified.
> > > 
> > > Thanks!
> > > 
> > > - Ben
> > > 
> > > On Sunday, 25 November 2012 at 5:11 PM, David Hong wrote:
> > > 
> > > Foreman defaults to port 5000 I think. Did you try port 5000?
> > > 
> > > Sent from my iPhone
> > > 
> > > On 25/11/2012, at 4:42 PM, Ben Taylor <me@taybenlor.com 
(mailto:me@taybenlor.com)> wrote:
> > > 
> > > Hey there,
> > > 
> > > I'm trying to get this running (thought I might poke around a node app,
> > > never have before).
> > > 
> > > I have node 0.8.14, npm 1.1.0 and successfully installed the packages.
> > > When I run foreman start it sits there and nothing happens. Doesn't seem to
> > > be accepting connections on 8001 either.
> > > 
> > > Any ideas?
> > > 
> > > - Ben
> > > 
> > > On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:
> > > 
> > > Awesome work, Gil!
> > > 
> > > 
> > > On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson
> > > <gilmoreorless@gmail.com (mailto:gilmoreorless@gmail.com)> wrote:
> > > 
> > > Hi all,
> > > 
> > > As Sharkie briefly mentioned at the last SydJS, I've upgraded 
sydjs.com (http://sydjs.com) to
> > > use Express 3.0 (instead of the old hand-rolled solution that Heroku forced
> > > upon us to begin with).
> > > 
> > > I pretty much just directly ported what we had over to Express, so there's
> > > definitely room for improvement. I also updated the readme to be a bit more
> > > useful for anyone who wants to work on the site.
> > > 
> > > Speaking of helping... we've still got the features wishlist available in
> > > the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist
> > > *hint hint*
> > > 
> > > Cheers,
> > > Gil
> > > 
> > 
> > 
> 
> 
> 

Re: [sydjs] Website updated to Express

From:
Jonathan Conway
Date:
2012-11-27 @ 00:08
Sounds good to me. I'd like us to work out the TODO list in better detail,
so we're clear on how the site should work.

Cheers,

Jonathan Conway  |  M +61 433 299 472  |  T @jonathanconway  |  ABN 59 729
468 524


On Tue, Nov 27, 2012 at 10:58 AM, Ben Taylor <me@taybenlor.com> wrote:

>  That'd be cool.
>
> I sketched out a new design last night and have some ideas.
>
> Perhaps we should use GitHub issues?
>
>  - Ben
>
> On Tuesday, 27 November 2012 at 10:54 AM, Sugendran Ganess wrote:
>
> Is there a list/google group where we can discuss options for the
> website? I've been writing nodejs fulltime for the last year and have
> a few ideas on things we can do. I figure spamming everyone with that
> conversation is probably a bad thing.
>
> On 27 November 2012 10:35, Jason Berry <jason@thevagabond.net> wrote:
>
> I've added some logging when the server starts to print the port the server
> is running on, which should help clear this up.
>
>
> On 25 November 2012 17:18, Ben Taylor <me@taybenlor.com> wrote:
>
>
> Aha! That worked. I'd poked through the app code and it had a default of
> 8001 specified.
>
> Thanks!
>
> - Ben
>
> On Sunday, 25 November 2012 at 5:11 PM, David Hong wrote:
>
> Foreman defaults to port 5000 I think. Did you try port 5000?
>
> Sent from my iPhone
>
> On 25/11/2012, at 4:42 PM, Ben Taylor <me@taybenlor.com> wrote:
>
> Hey there,
>
> I'm trying to get this running (thought I might poke around a node app,
> never have before).
>
> I have node 0.8.14, npm 1.1.0 and successfully installed the packages.
> When I run foreman start it sits there and nothing happens. Doesn't seem to
> be accepting connections on 8001 either.
>
> Any ideas?
>
> - Ben
>
> On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:
>
> Awesome work, Gil!
>
>
> **On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson
> <gilmoreorless@gmail.com> wrote:
>
> Hi all,
>
> As Sharkie briefly mentioned at the last SydJS, I've upgraded sydjs.com to
> use Express 3.0 (instead of the old hand-rolled solution that Heroku forced
> upon us to begin with).
>
> I pretty much just directly ported what we had over to Express, so there's
> definitely room for improvement. I also updated the readme to be a bit more
> useful for anyone who wants to work on the site.
>
> Speaking of helping... we've still got the features wishlist available in
> the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist
> *hint hint*
>
> Cheers,
> Gil
>
>
>

Re: [sydjs] Website updated to Express

From:
Ben Taylor
Date:
2012-11-27 @ 00:19
I've added some very broad issues in GitHub. 

https://github.com/sydjs/sydjs/issues 

We can use those issues for discussion, then break them down as required.

 - Ben


On Tuesday, 27 November 2012 at 11:08 AM, Jonathan Conway wrote:

> Sounds good to me. I'd like us to work out the TODO list in better 
detail, so we're clear on how the site should work.
> 
> Cheers,
> 
> Jonathan Conway  |  M +61 433 299 472  |  T @jonathanconway  |  ABN 59 
729 468 524
> 
> 
> On Tue, Nov 27, 2012 at 10:58 AM, Ben Taylor <me@taybenlor.com 
(mailto:me@taybenlor.com)> wrote:
> > That'd be cool. 
> > 
> > I sketched out a new design last night and have some ideas.
> > 
> > Perhaps we should use GitHub issues? 
> > 
> >  - Ben
> > 
> > 
> > On Tuesday, 27 November 2012 at 10:54 AM, Sugendran Ganess wrote:
> > 
> > > Is there a list/google group where we can discuss options for the
> > > website? I've been writing nodejs fulltime for the last year and have
> > > a few ideas on things we can do. I figure spamming everyone with that
> > > conversation is probably a bad thing.
> > > 
> > > On 27 November 2012 10:35, Jason Berry <jason@thevagabond.net 
(mailto:jason@thevagabond.net)> wrote:
> > > > I've added some logging when the server starts to print the port 
the server
> > > > is running on, which should help clear this up.
> > > > 
> > > > 
> > > > On 25 November 2012 17:18, Ben Taylor <me@taybenlor.com 
(mailto:me@taybenlor.com)> wrote:
> > > > > 
> > > > > Aha! That worked. I'd poked through the app code and it had a default of
> > > > > 8001 specified.
> > > > > 
> > > > > Thanks!
> > > > > 
> > > > > - Ben 
> > > > > 
> > > > > On Sunday, 25 November 2012 at 5:11 PM, David Hong wrote:
> > > > > 
> > > > > Foreman defaults to port 5000 I think. Did you try port 5000?
> > > > > 
> > > > > Sent from my iPhone
> > > > > 
> > > > > On 25/11/2012, at 4:42 PM, Ben Taylor <me@taybenlor.com 
(mailto:me@taybenlor.com)> wrote:
> > > > > 
> > > > > Hey there,
> > > > > 
> > > > > I'm trying to get this running (thought I might poke around a node app, 
> > > > > never have before).
> > > > > 
> > > > > I have node 0.8.14, npm 1.1.0 and successfully installed the packages.
> > > > > When I run foreman start it sits there and nothing happens. 
Doesn't seem to
> > > > > be accepting connections on 8001 either.
> > > > > 
> > > > > Any ideas?
> > > > > 
> > > > > - Ben
> > > > > 
> > > > > On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:
> > > > > 
> > > > > Awesome work, Gil!
> > > > > 
> > > > > 
> > > > > On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson
> > > > > <gilmoreorless@gmail.com (mailto:gilmoreorless@gmail.com)> wrote:
> > > > > 
> > > > > Hi all,
> > > > > 
> > > > > As Sharkie briefly mentioned at the last SydJS, I've upgraded 
sydjs.com (http://sydjs.com) to
> > > > > use Express 3.0 (instead of the old hand-rolled solution that 
Heroku forced
> > > > > upon us to begin with).
> > > > > 
> > > > > I pretty much just directly ported what we had over to Express, 
so there's
> > > > > definitely room for improvement. I also updated the readme to be
a bit more
> > > > > useful for anyone who wants to work on the site.
> > > > > 
> > > > > Speaking of helping... we've still got the features wishlist 
available in
> > > > > the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist
> > > > > *hint hint*
> > > > > 
> > > > > Cheers,
> > > > > Gil
> > > > > 
> > > > 
> > > > 
> > > > 
> > > 
> > > 
> > > 
> > > 
> > 
> > 
> 

Re: [sydjs] Website updated to Express

From:
Lachlan Hardy
Date:
2012-11-27 @ 00:29
Cool. While we're at it:

If anybody else wants access to the GitHub project or to deploy to Heroku,
please email me relevant details to Lachlan@lachstock.com.au and I'll set
you up.


On Tue, Nov 27, 2012 at 11:19 AM, Ben Taylor <me@taybenlor.com> wrote:

>  I've added some very broad issues in GitHub.
>
> https://github.com/sydjs/sydjs/issues
>
> We can use those issues for discussion, then break them down as required.
>
>  - Ben
>
> On Tuesday, 27 November 2012 at 11:08 AM, Jonathan Conway wrote:
>
> Sounds good to me. I'd like us to work out the TODO list in better detail,
> so we're clear on how the site should work.
>
> Cheers,
>
> Jonathan Conway  |  M +61 433 299 472  |  T @jonathanconway  |  ABN 59
> 729 468 524
>
>
> On Tue, Nov 27, 2012 at 10:58 AM, Ben Taylor <me@taybenlor.com> wrote:
>
>  That'd be cool.
>
> I sketched out a new design last night and have some ideas.
>
> Perhaps we should use GitHub issues?
>
>  - Ben
>
> On Tuesday, 27 November 2012 at 10:54 AM, Sugendran Ganess wrote:
>
> Is there a list/google group where we can discuss options for the
> website? I've been writing nodejs fulltime for the last year and have
> a few ideas on things we can do. I figure spamming everyone with that
> conversation is probably a bad thing.
>
> On 27 November 2012 10:35, Jason Berry <jason@thevagabond.net> wrote:
>
> I've added some logging when the server starts to print the port the server
> is running on, which should help clear this up.
>
>
> On 25 November 2012 17:18, Ben Taylor <me@taybenlor.com> wrote:
>
>
> Aha! That worked. I'd poked through the app code and it had a default of
> 8001 specified.
>
> Thanks!
>
> - Ben
>
> On Sunday, 25 November 2012 at 5:11 PM, David Hong wrote:
>
> Foreman defaults to port 5000 I think. Did you try port 5000?
>
> Sent from my iPhone
>
> On 25/11/2012, at 4:42 PM, Ben Taylor <me@taybenlor.com> wrote:
>
> Hey there,
>
> I'm trying to get this running (thought I might poke around a node app,
> never have before).
>
> I have node 0.8.14, npm 1.1.0 and successfully installed the packages.
> When I run foreman start it sits there and nothing happens. Doesn't seem to
> be accepting connections on 8001 either.
>
> Any ideas?
>
> - Ben
>
> On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:
>
> Awesome work, Gil!
>
>
> **On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson
> <gilmoreorless@gmail.com> wrote:
>
> Hi all,
>
> As Sharkie briefly mentioned at the last SydJS, I've upgraded sydjs.com to
> use Express 3.0 (instead of the old hand-rolled solution that Heroku forced
> upon us to begin with).
>
> I pretty much just directly ported what we had over to Express, so there's
> definitely room for improvement. I also updated the readme to be a bit more
> useful for anyone who wants to work on the site.
>
> Speaking of helping... we've still got the features wishlist available in
> the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist
> *hint hint*
>
> Cheers,
> Gil
>
>
>
>
>

Re: [sydjs] Website updated to Express

From:
Lachlan Hardy
Date:
2012-11-27 @ 00:01
Yeah, we already use the wiki for a wishlist:
https://github.com/sydjs/sydjs/wiki/Website-wishlist

So using Issues seems the right approach. Then those who want in can
subscribe appropriately.


On Tue, Nov 27, 2012 at 10:58 AM, Ben Taylor <me@taybenlor.com> wrote:

>  That'd be cool.
>
> I sketched out a new design last night and have some ideas.
>
> Perhaps we should use GitHub issues?
>
>  - Ben
>
> On Tuesday, 27 November 2012 at 10:54 AM, Sugendran Ganess wrote:
>
> Is there a list/google group where we can discuss options for the
> website? I've been writing nodejs fulltime for the last year and have
> a few ideas on things we can do. I figure spamming everyone with that
> conversation is probably a bad thing.
>
> On 27 November 2012 10:35, Jason Berry <jason@thevagabond.net> wrote:
>
> I've added some logging when the server starts to print the port the server
> is running on, which should help clear this up.
>
>
> On 25 November 2012 17:18, Ben Taylor <me@taybenlor.com> wrote:
>
>
> Aha! That worked. I'd poked through the app code and it had a default of
> 8001 specified.
>
> Thanks!
>
> - Ben
>
> On Sunday, 25 November 2012 at 5:11 PM, David Hong wrote:
>
> Foreman defaults to port 5000 I think. Did you try port 5000?
>
> Sent from my iPhone
>
> On 25/11/2012, at 4:42 PM, Ben Taylor <me@taybenlor.com> wrote:
>
> Hey there,
>
> I'm trying to get this running (thought I might poke around a node app,
> never have before).
>
> I have node 0.8.14, npm 1.1.0 and successfully installed the packages.
> When I run foreman start it sits there and nothing happens. Doesn't seem to
> be accepting connections on 8001 either.
>
> Any ideas?
>
> - Ben
>
> On Sunday, 25 November 2012 at 11:10 AM, Lachlan Hardy wrote:
>
> Awesome work, Gil!
>
>
> **On Sat, Nov 24, 2012 at 10:31 PM, Gilmore Davidson
> <gilmoreorless@gmail.com> wrote:
>
> Hi all,
>
> As Sharkie briefly mentioned at the last SydJS, I've upgraded sydjs.com to
> use Express 3.0 (instead of the old hand-rolled solution that Heroku forced
> upon us to begin with).
>
> I pretty much just directly ported what we had over to Express, so there's
> definitely room for improvement. I also updated the readme to be a bit more
> useful for anyone who wants to work on the site.
>
> Speaking of helping... we've still got the features wishlist available in
> the wiki: https://github.com/sydjs/sydjs/wiki/Website-wishlist
> *hint hint*
>
> Cheers,
> Gil
>
>
>