librelist archives

« back to archive

Possible problem with pip install --use-wheel

Possible problem with pip install --use-wheel

From:
Paul Moore
Date:
2012-10-20 @ 11:52
I just tried to install a wheel for ipython and I got a dependency
required that I think is wrong. This is around extras, which I am very
unfamiliar with, so bear with me if I did something stupid...

I wanted to do
    pip.exe install --use-wheel --no-index -f .\Wheels "ipython[notebook]"

From myunderstanding, this should install ipython and require tornado.
I have wheels for both of these. Now, to be honest, I think this is
somewhat wrong, as the ipython notebook also requires zmq, but that's
a separate matter for now... When I did the isnatll, I got

>.\v33\Scripts\pip.exe install --use-wheel --no-index -f .\Wheels 
"ipython[notebook]"
Ignoring indexes: http://pypi.python.org/simple/
Downloading/unpacking ipython[notebook]
Downloading/unpacking nose>=0.10.1 (from ipython[notebook])
Downloading/unpacking pyreadline>=1.7.1 (from ipython[notebook])
Downloading/unpacking pyzmq>=2.1.4 (from ipython[notebook])
Downloading/unpacking pygments (from ipython[notebook])
Downloading/unpacking sphinx>=0.3 (from ipython[notebook])
Downloading/unpacking tornado>=2.0 (from ipython[notebook])
Downloading/unpacking jinja2>=2.3 (from sphinx>=0.3->ipython[notebook])
Downloading/unpacking docutils>=0.7 (from sphinx>=0.3->ipython[notebook])
Downloading/unpacking babel>=0.8 (from
jinja2>=2.3->sphinx>=0.3->ipython[notebook])
  Could not find any downloads that satisfy the requirement babel>=0.8
(from jinja2>=2.3->sphinx>=0.3->ipython[notebook])
No distributions at all found for babel>=0.8 (from
jinja2>=2.3->sphinx>=0.3->ipython[notebook])

It seems to be downloading *all* the optional dependencies, ignoring
the stated extras I want. Looking at the metadata file in the wheel,
this is the relevant part:

Requires-Dist: pyreadline (>=1.7.1)
Provides-Extra: parallel
Requires-Dist: pyzmq (>=2.1.4); extra == 'parallel'
Provides-Extra: zmq
Requires-Dist: pyzmq (>=2.1.4); extra == 'zmq'
Provides-Extra: notebook
Requires-Dist: tornado (>=2.0); extra == 'notebook'
Provides-Extra: qtconsole
Requires-Dist: pygments; extra == 'qtconsole'
Provides-Extra: doc
Requires-Dist: sphinx (>=0.3); extra == 'doc'
Provides-Extra: test
Requires-Dist: nose (>=0.10.1); extra == 'test'

Is this a bug? And if so, where?

For comparison, a source install:
    .\v33\Scripts\pip.exe install --no-index -f .\Sdists ipython[notebook]

worked.

Paul.

Re: [wheel] Possible problem with pip install --use-wheel

From:
Daniel Holth
Date:
2012-10-20 @ 12:01
It's a bug. Install markerlib, or distribute 0.6.29 as just released.
On Oct 20, 2012 7:52 AM, "Paul Moore" <p.f.moore@gmail.com> wrote:

> I just tried to install a wheel for ipython and I got a dependency
> required that I think is wrong. This is around extras, which I am very
> unfamiliar with, so bear with me if I did something stupid...
>
> I wanted to do
>     pip.exe install --use-wheel --no-index -f .\Wheels "ipython[notebook]"
>
> >From myunderstanding, this should install ipython and require tornado.
> I have wheels for both of these. Now, to be honest, I think this is
> somewhat wrong, as the ipython notebook also requires zmq, but that's
> a separate matter for now... When I did the isnatll, I got
>
> >.\v33\Scripts\pip.exe install --use-wheel --no-index -f .\Wheels
> "ipython[notebook]"
> Ignoring indexes: http://pypi.python.org/simple/
> Downloading/unpacking ipython[notebook]
> Downloading/unpacking nose>=0.10.1 (from ipython[notebook])
> Downloading/unpacking pyreadline>=1.7.1 (from ipython[notebook])
> Downloading/unpacking pyzmq>=2.1.4 (from ipython[notebook])
> Downloading/unpacking pygments (from ipython[notebook])
> Downloading/unpacking sphinx>=0.3 (from ipython[notebook])
> Downloading/unpacking tornado>=2.0 (from ipython[notebook])
> Downloading/unpacking jinja2>=2.3 (from sphinx>=0.3->ipython[notebook])
> Downloading/unpacking docutils>=0.7 (from sphinx>=0.3->ipython[notebook])
> Downloading/unpacking babel>=0.8 (from
> jinja2>=2.3->sphinx>=0.3->ipython[notebook])
>   Could not find any downloads that satisfy the requirement babel>=0.8
> (from jinja2>=2.3->sphinx>=0.3->ipython[notebook])
> No distributions at all found for babel>=0.8 (from
> jinja2>=2.3->sphinx>=0.3->ipython[notebook])
>
> It seems to be downloading *all* the optional dependencies, ignoring
> the stated extras I want. Looking at the metadata file in the wheel,
> this is the relevant part:
>
> Requires-Dist: pyreadline (>=1.7.1)
> Provides-Extra: parallel
> Requires-Dist: pyzmq (>=2.1.4); extra == 'parallel'
> Provides-Extra: zmq
> Requires-Dist: pyzmq (>=2.1.4); extra == 'zmq'
> Provides-Extra: notebook
> Requires-Dist: tornado (>=2.0); extra == 'notebook'
> Provides-Extra: qtconsole
> Requires-Dist: pygments; extra == 'qtconsole'
> Provides-Extra: doc
> Requires-Dist: sphinx (>=0.3); extra == 'doc'
> Provides-Extra: test
> Requires-Dist: nose (>=0.10.1); extra == 'test'
>
> Is this a bug? And if so, where?
>
> For comparison, a source install:
>     .\v33\Scripts\pip.exe install --no-index -f .\Sdists ipython[notebook]
>
> worked.
>
> Paul.
>

Re: [wheel] Possible problem with pip install --use-wheel

From:
Paul Moore
Date:
2012-10-20 @ 12:37
On 20 October 2012 13:01, Daniel Holth <dholth@gmail.com> wrote:
> It's a bug. Install markerlib, or distribute 0.6.29 as just released.

To be clear, you're saying it's not correct behaviour, but it happens
because markerlib isn't available and installing markerlib/distribute
0.6.29 is the correct fix? OK, that's great (I recall some comments on
one of the patch comment threads that I guess were about this, but I
didn't understand them at the time).

Thanks,
Paul.