librelist archives

« back to archive

I got error when install py-yajl on MAC

I got error when install py-yajl on MAC

From:
GuoJing
Date:
2010-09-01 @ 08:45
hi:
    I got error when install py-yajl by using easy_install, I searched
    google but cannot find any answer, could anyone help me?

    Thanks

    Error message is:

Traceback (most recent call last):
  File "setup.py", line 64, in <module>
    subprocess.call(['git', 'submodule', 'update',])
  File 
"/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/subprocess.py",
line 480, in call
    return Popen(*popenargs, **kwargs).wait()
  File 
"/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/subprocess.py",
line 633, in __init__
    errread, errwrite)
  File 
"/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/subprocess.py",
line 1139, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory


----------
Guo Jing

Re: [yajl] I got error when install py-yajl on MAC

From:
Hatem Nassrat
Date:
2010-09-01 @ 09:04
It seems py-yajl requires some use of git. Check/install git on your system
and see if it works better.

-- 
Hatem Nassrat
http://pykler.github.com/

On 1 Sep 2010 05:46, "GuoJing" <soundbbg@gmail.com> wrote:

hi:
   I got error when install py-yajl by using easy_install, I searched
   google but cannot find any answer, could anyone help me?

   Thanks

   Error message is:

Traceback (most recent call last):
 File "setup.py", line 64, in <module>
   subprocess.call(['git', 'submodule', 'update',])
 File

"/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/subprocess.py",
line 480, in call
   return Popen(*popenargs, **kwargs).wait()
 File

"/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/subprocess.py",
line 633, in __init__
   errread, errwrite)
 File

"/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/subprocess.py",
line 1139, in _execute_child
   raise child_exception
OSError: [Errno 2] No such file or directory


----------
Guo Jing

Re: [yajl] I got error when install py-yajl on MAC

From:
GuoJing
Date:
2010-09-01 @ 09:29
Is source control tool called git?

On Wed, Sep 01, 2010 at 06:04:55AM -0300, Hatem Nassrat wrote:
> It seems py-yajl requires some use of git. Check/install git on your system
> and see if it works better.
> 
> -- 
> Hatem Nassrat
> http://pykler.github.com/
> 
> On 1 Sep 2010 05:46, "GuoJing" <soundbbg@gmail.com> wrote:
> 
> hi:
>    I got error when install py-yajl by using easy_install, I searched
>    google but cannot find any answer, could anyone help me?
> 
>    Thanks
> 
>    Error message is:
> 
> Traceback (most recent call last):
>  File "setup.py", line 64, in <module>
>    subprocess.call(['git', 'submodule', 'update',])
>  File
> 
"/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/subprocess.py",
> line 480, in call
>    return Popen(*popenargs, **kwargs).wait()
>  File
> 
"/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/subprocess.py",
> line 633, in __init__
>    errread, errwrite)
>  File
> 
"/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/subprocess.py",
> line 1139, in _execute_child
>    raise child_exception
> OSError: [Errno 2] No such file or directory
> 
> 
> ----------
> Guo Jing

Re: [yajl] I got error when install py-yajl on MAC

From:
Hatem Nassrat
Date:
2010-09-01 @ 09:31
Yes

On 1 Sep 2010 06:29, "GuoJing" <soundbbg@gmail.com> wrote:

Is source control tool called git?


On Wed, Sep 01, 2010 at 06:04:55AM -0300, Hatem Nassrat wrote:
> It seems py-yajl requires some use...

Re: [yajl] I got error when install py-yajl on MAC

From:
GuoJing
Date:
2010-09-01 @ 09:35
Thanks!

fix that problem. It's really hard for me find connection between yajl
and git.

anyway thanks!!

On Wed, Sep 01, 2010 at 06:31:13AM -0300, Hatem Nassrat wrote:
> Yes
> 
> On 1 Sep 2010 06:29, "GuoJing" <soundbbg@gmail.com> wrote:
> 
> Is source control tool called git?
> 
> 
> On Wed, Sep 01, 2010 at 06:04:55AM -0300, Hatem Nassrat wrote:
> > It seems py-yajl requires some use...

Re: [yajl] I got error when install py-yajl on MAC

From:
R. Tyler Croy
Date:
2010-09-01 @ 15:34
On Wed, 01 Sep 2010, GuoJing wrote:

> Thanks!
> 
> fix that problem. It's really hard for me find connection between yajl
> and git.
> 
> anyway thanks!!

Sorry about that, I need to remove that check from the source tarball. I
origianlly added it for folks using a git checkout of py-yajl.


- R. Tyler Croy
--------------------------------------
  GitHub: http://github.com/rtyler
 Twitter: http://twitter.com/agentdero